Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I bring my Windows XP (SP3) laptop home I can still login as my domain account because Windows caches the info necessary to authenticate me when the domain controller isn't around.

However, when I try to connect to the local SQL Server (2008) Integration Services from within SQL Server Management Studio, it generates SSPI context errors. The only way it works is if I connect to the office with VPN or if I'm at the office where the domain controller is. I have both SQL Server Agent and SQL Server Integration Services 10 running under local computer accounts.

It seems that the only option to connect to Integration Services from within Management Studio is to use Window authentication. Is there any way to do this when I'm not connected to the office? Why don't these services use the cached info just like Windows Login?

Thanks.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You cannot. SQL Server needs to connect to AD when validating a login and won't work with cached credentials, that's just they way it is. You must use a local account if you want to work while not disconnected from domain ( LAPTOPNAME\UserName) .

Another alternative is to implement DirectAccess in your corp net, which would eliminate the need for VPN.

share|improve this answer

I realise this is old but I managed to get by this issue via this post:

SQL SERVER – Fix : Error: 4064 – Cannot open user default database. Login failed. Login failed for user

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.