Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to enable ports 25 - 28 on my 28 port Catalyst 3750. These four ports are my fiber ports. I am using the following command to bring up that interface.

interface range Gi1/0/25 - 28

That works and it dumps me in the config-if-interface prompt. This is where I get stuck. I just want to enable these four ports and have them be in VLAN1 and On just like ports 1 - 24.

How do I do this?

share|improve this question

3 Answers 3

up vote 15 down vote accepted

First of all, do a show running-config interface GigabitEthernet 1/0/X and have a look at how those interfaces are actually configured.

Then do what is needed:

  • If they are in shutdown state, issue a no shutdown command.
  • If they are not in the right VLAN, issue a switchport access vlan X command.
  • If they are configured for something else than standard access (i.e. trunking), clear their configuration and reconfigure them.
share|improve this answer
Could also do "sh int status" for a quick view look at all interfaces. But Massimo hit the nail on the head with his answer. – Webs Apr 8 '10 at 21:23
I issued a "no shutdown" to the interface range Gi1/0/25 - 28. Although when I back out to the non-enabled prompt and do a "show interface Gi1/0/25" the output states that Gigabit ethernet 1/0/25 is down, line protocol is down (not connected)". Ports 25 - 28 are still not connected. – Jared Brown Apr 8 '10 at 21:48
This may be a silly question, but are they actually connected to something? The fact that they say "down" and not "administratively down" means they are enabled. The switch just doesn't see anything connected to them. Do you have SFP modules inserted? The output of show int Gi1/0/25 (or 26-28) should have a line showing the media type, such as media type is SX, or media type is Not Present if there is no SFP module installed. – James Sneeringer Apr 8 '10 at 22:09
Agreed. "Line protocol is down" states clearly that the switch thinks there isn't anything connected to those interfaces, so you should have a look at cabling and at whatever is at the other end. – Massimo Apr 9 '10 at 4:52

Do the ports require GBICs (and, if so, do you have GBICs installed)? Do you have cables attached to the ports? If you're using fibre, you MAY have to swap the connectors around (I don't think this is possible for SFP connectors, so you'd have to have a cross-over cable or a connector that allows you to connect RX on one cable to TX on the other).

share|improve this answer
You've got quite confused ideas, haven't you? – Massimo Apr 10 '10 at 5:01
Not necessarily. Off-hand, I don't recall if ports 25-28 require GBICs or not (if they're GBIC ports, they'll just be slots in the chassis). I guess I could check it, but... Missing cables happen, a lot, especially when different people deal with the physical install and configuration. Fibres being the wrong way around is painfully common. – Vatine Apr 12 '10 at 13:37

Have you tried: - a show interface gi1/0/25 capabilities to see if the switch recognizes the SFP? - checked that the SFP type works with the fiber type you are trying to use? - The fiber path in properly patch and consistently the same type of fiber? - The switch on the other end has a compatible SFP as well? - some interfaces allow speed changes to be configured, you might check that the switches are configured the same on both sides.

I took a short LC and flipped the TX - RX, so that I can default the interface do a no shut, then plug in the tester to two interfaces on the same switch. That will eliminate the other switch and the path if the link doesn't come up.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.