Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm setting up a new terminal server for our users on Win2008R2 (I guess I should call it Remote Desktop Services now!)

When I try to change the location of "Documents" (by removing the default Documents library and adding a new one), to use the file server ie \\fileserver\username\Documents I get the message:

"This network location can't be included because it is not indexed"

I certainly don't want to make folders available offline, and in fact, I have set the GPO to prohibit offline folders on the terminal servers.

What is the best practice for document libraries on terminal server and network file shares?

share|improve this question
1  
Using Group Policy to configure Folder Redirection is the best practice method for redirecting user documents in a TS/RDS session. –  joeqwerty Nov 21 '12 at 5:24
add comment

1 Answer 1

Having the same issue, 2008 R2 RDS. Unable to add any network folders, regardless of the host platform or search index settings. Tried a folder on a 2003 server. The 2003 server has Search 4.0 loaded, and the target folder is indexed. I am able to add that folder to the library of several Windows 7 Professional workstations without issue, but RDS on 2008 R2 rejects the folder with the "not indexed" message.

Cannot add folders on another 2008 R2 server with Windows Search role installed. Even tried removing Windows Search and adding Indexing role instead, still no go. Also can't add folders that are indexed on Windows 7 systems. Have also tried various sharing and discovery options on the 2008 server; none seem to change the behavior, yet I can add any of these folders to a Windows 7 workstation without problems.

The popular symbolic link workaround for Windows 7 does work, but I've found that many utilities and backup programs do not handle those links correctly, and users are confused by the misleading drive letter prefix on the file paths, so that workaround creates other issues.

Have concluded that this must either be a bug, or there is some undiscovered security setting that is preventing it from working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.