Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The product I'm working on has both a US and UK version. We have a service that is not picking up the correct resx file on our UK test server. After tracking it down through code, we have the correct CurrentCulture set up to "en-GB" but the CurrentUICulture is still "en-US".

Obviously we don't have something set correctly. How do you correctly set up an UK VM from an US machine?

This is on Windows Server 2003

share|improve this question
    
Any particular operating system? –  Ignacio Vazquez-Abrams Apr 9 '10 at 14:22
    
Windows Server 2003. Forgot people can't read minds –  Strop Apr 9 '10 at 14:34

3 Answers 3

From MS KB article here:

1 Press Start -> Settings -> Control Panel -> Regional Options.

2 From the "Your local (Location)" list box, choose the appropriate location to set the user local (Including format for Date ,Currency ,Time ,Numbers ,..etc.)

3 From the "Set default" button, choose the language which will be default for your operating system , for example if you choose Arabic as default then the ANSI application will display Arabic text correctly.

4 Press "OK" button then restart.

Note: Changing the system locale will take affect after the system is rebooted, while changing the user locale only does not required system rebooting.

Changing the system locale requires locale system administrative privileges, while changing the user locale does not.

I imagine selecting "English (United Kingdom)" will get you what you want.

share|improve this answer
    
I have these settings already set to UK but still no good. –  Strop Apr 9 '10 at 17:35

I was doing this today, but in reverse - UK to US & Canada. The likely problem is that the control panel option to 'Apply all settings to the current user account and to the default user profile' will only update .DEFAULT and S-1-5-18 (the local system account). Most of your services will be running under S-1-5-19 (local service) and S-1-5-20 (network service - full list here).

What I did was:

  1. Use the control panel to set system default to the desired locale
  2. Open up regedit and navigate to HKEY_Users\S-1-5-18\Control Panel\International
  3. Confirm that the desired local is shown in the right panel, if not return to 1 or try rebooting or something
  4. Right click on the International key in the left panel and export it to a S-1-5-18.reg file
  5. Make a copy of the file and rename it S-1-5-19.reg
  6. Open S-1-5-19.reg up in notepad and replace the two instances of S-1-5-18 with S-1-5-19
  7. Repeat 5 & 6 except with S-1-5-20
  8. Import both S-1-5-19.reg and S-1-5-20.reg (double click and OK)
  9. Reboot server

If you're planning to do a lot of this, you may want to export some registry files with the US settings as well - I now have a set of reg files for UK, US and Canada so I can switch my VM with a few double clicks and a reboot.

share|improve this answer

If it is a virtual server, then why not just set up from scratch a new virtual server, and when installing it set all the location details to United Kingdom? If everything else has failed then that may save you time hunting down what was set wrong. And that doesn't work, I guess perhaps there is somewhere else in your code that is causing the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.