Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to copy files on a SMB fileshare. When I attempt to copy the files in Finder, I get the following error:

 The operation can’t be completed because you don’t have permission to access some of the items.

Copying via Terminal.app (using a simple cp command) works just fine.

Permissions on the folders (as seen from the computer attached to the fileshare) are as follows:

Source:

 dr-xr-x---   2 smokris  staff    16384 Oct 13 10:55 .
 dr-xr-x---@ 61 smokris  staff    16384 Oct 13 10:56 ..
 -r--r-----   1 smokris  staff    53970 Oct 13 10:55 ._IMG_3823.JPG
 -r--r-----@  1 smokris  staff  3135600 Oct 13 10:55 IMG_3823.JPG

Destination:

 drwxrwx---  2 smokris  staff    16384 Apr  9 10:17 .
 drwxrwx---  3 smokris  staff    16384 Apr  9 10:15 ..

Any ideas?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Turned out to be a bug introduced by the recent 10.6.3 release (10.6.2 worked just fine for the same test case).

Adding unix extensions = no to the [global] section in /etc/samba/smb.conf solved the problem for me (found on http://splatdot.com/fixing-snow-leopard-10-6-3-samba-write-access/, which unfortunately wasn't on the first few pages of the google search results for the Finder error message when I posted this question).

share|improve this answer
    
You saved my day. –  Palantir Nov 21 '10 at 10:58
add comment

This could come from extensible attribute set on the file (@ sign on the line) You can do ls -l@ to see them.

Do a copy of the file in the finder, them remove extended attribute with xattr attr_name file (do ls -l@ to see attr_name)

Then try to copy the file on the SMB share.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.