Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a contractor connected to a CIFS share (port 445). He's not a big shop (so no go on using VPN). His ISP blocks outgoing connections on port 445.

I've been doing some rsync to ftp madness as a workaround to have the share available to him, but it's getting out of control -- we're syncing nearly 40GB a day to an external ftp site and it's going to be much easier just to have him connect and only grab the stuff he needs.

So... I can have the CIFS share open to the internet (filtered to allow access to his IP only) on port 446. How the heck can he connect to that?

I looked through "net use" and didn't see anything about using another port.

share|improve this question
up vote 2 down vote accepted

Short answer, use a VPN. I don't think even Samba would support this without changing the code.

Longer answer, use another method like WebDAV that can be securly run over the public internet (albeit don't try and use the internal Windows WebDAV client, I've not managed to make it work on XP or Win 7).

share|improve this answer
    
WebDAV or FTP will probably have to be the solution. Thanks! – fsckin Apr 11 '10 at 20:06

If you dont want to use a vpn, you can use an ubuntu pc or virtual machine as the client (this is free, jsut download vmplayer from vmware and you can even download pre-made vm's), and for the windows host no changes need to be made, however at your router do a port forward with translation. I translated 445 to 4450 and my client is my android phone using the paid for version of the app FX which i LOVE! I will let you know if i can configure ubuntu as a client but im sure its something easy like \server:port\share...

Also webdav does work using windows 7 sp1 builtin client IF you disable autodetect in your internet explorer settings under the connection tab. If you dont disable it, it will stall for 30 seconds per connection attempt and annoy you while it waits for autodiscover to time out in the background.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.