Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Since my new ISP installed their own router to my house(I rented a room in a student house so don't have much control on these), I started having strange delays. Any outgoing connection I do, be it http or ssh, is delayed for several seconds, and once it is established, I have no further problems. I open several simultaneous tabs in my browser and after about 5 to 8 seconds, they all connect and load simultaneously and quiet fast. I can actually play online games once I connect.What's more interesting is, I experience this only with Linux distros, namely Arch and some versions of Ubuntu. Access with Windows installs are quiet normal. What might be wrong with my router? Everything was fine with my old router but I have to use this one now.

share|improve this question

closed as off topic by Mark Henderson Jul 31 '12 at 3:33

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Possibly a superuser question. –  pehrs Apr 11 '10 at 13:29
    
addendum: I use DHCP for everything including DNS on my all installs. –  Atilla Filiz Apr 11 '10 at 16:13
    
[Solved] Manually setting the DNS to third party(google) ans using wireless instead of etherned solved the problem, though I have no idea why it worked. –  Atilla Filiz Apr 12 '10 at 7:09

2 Answers 2

up vote 1 down vote accepted

Two likely things, first as perhrs says, DNS.

Second, IPv6. There's a chance that if the ISP is academic related they could have IPv6 enabled, but broken.

You could easily be seeing a combination of this as it's been known that many bad (consumer) routers drop AAAA (IPv6) DNS queries on the floor, Windows normally won't do IPv6 lookups unless it thinks it has a working IPv6 connection.

A way to test this would be to try host ipv6.google.com (linux) or nslookup ipv6.google.com (windows). If these requests time out you have your culprit. To work around you could use third-party DNS servers (eg, OpenDNS, Google), or your ISP's DNS servers directly. You should also request a firmware update from the ISP to fix the issue.

share|improve this answer
1  
host ipv6.google.com resolves the host. No problem there. Manually setting the DNS solved the problem but I have no idea why it worked. –  Atilla Filiz Apr 12 '10 at 7:08

My first reaction is DNS. Check the DNS configuration of your linux systems so it's not hitting a DNS server that is down.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.