Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After upgrading to Drupal 6.12 I can no longer access the admin section on my site - I get a page not found error.
Things I've been able to test/check:

  • I have clean URLs enabled but trying to bypass them doesn't work either, and urls in the rest of the site are fine. So I doubt it's that.
  • The menu_router table is also looks fine.
  • I've confirmed the .htaccess is setup correct and so is Mod_Rewrite.
  • The rest of the site works fine
  • I have set the base url in the settings.php with no effect
  • I had rootcandy for the theme for the admin section and have removed that to be sure.

Any ideas for other things to try?

share|improve this question
    
index.php?q=admin doesn't work? –  ceejayoz May 27 '09 at 17:55
    
No it didn't work either –  Robert MacLean May 27 '09 at 19:11
add comment

3 Answers

up vote 3 down vote accepted

I managed to resolve it by disabling the update module in the system database using a SQL command similar to this:

UPDATE system SET status=0 WHERE name="update";
share|improve this answer
1  
did you get errors in the error log? have you looked at the dblog/watchdog table to see why it was going wrong? –  Stewart Robinson May 27 '09 at 21:20
    
alternately, you can use drush: drush pm-disable update --y –  doub1ejack Feb 13 '13 at 21:00
add comment

This has happened to me a couple times on a site I've been working with lately. A couple of these answer worked at different times when I encountered it except for the last time. It ended up being incorrect values for $base_url and $cookie_domain in the settings file.

Problem aros with a site that is using one settings file (sites/default/settings.php) incorrectly across multiple servers (dev/staging/production).

share|improve this answer
add comment

Sadly this has happened to me more than a few times. Along with my other answer, another solution is to increase the memory limit on the server. (I think most users would normally be able to solve this themselves but there may be a setting that instead of giving errors, Drupal just dumps to a 404. Which is less than helpful.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.