Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can't find a repository that contains ruby 1.8.7. All repos only contain 1.8.5 or 1.8.6 versions.

Does anyone know of any repos with ruby-1.8.7?

share|improve this question
1  
You forgot your question. –  Ignacio Vazquez-Abrams Apr 11 '10 at 18:30
    
What version of centos are you running? –  Andrew Case Sep 25 '11 at 3:58

3 Answers 3

up vote 2 down vote accepted

RBEL Repo provides Ruby packages for RHEL based distro's.

share|improve this answer

I can't either but you can still install from rpm.

Here are some links.

cherpec.com

Previous serverfault.com question

Obviously as these are unknown third party sources, you should make your own assessment on the security implications.

share|improve this answer
    
SMiX, How did you finally resolve this. Did you install ruby 1.8.7 from rpm or are you sticking with a version in the repos? –  Richard Holloway Aug 13 '10 at 23:37
    
Based on his later question, itsabear solved it by switching to Ubuntu. –  Rilindo Nov 25 '11 at 23:15
1  
@Rilindo: I find that solves a lot of problems with CentOS. –  Richard Holloway Feb 8 '12 at 14:43

I also searched for a more recent ruby for RHEL 5 / centos, nothing found. Maybe other, recent ruby versions break other things...

share|improve this answer
    
Indeed, it will probably break all extensions compiled against the shipped version of Ruby, so you'll need to recompile extensions and packages that you want to use with it. RHEL/CentOS usually remains on a single major version of a package to provide ABI stability and compatibility. –  m0dlx Jul 24 '11 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.