Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting the following error when I try to install mod_wsgi

./configure 

checking for apxs2... no
checking for apxs... /usr/sbin/apxs
checking Apache version... 2.2.3
configure: creating ./config.status
config.status: creating Makefile

make

/usr/sbin/apxs -c -I/usr/local/include/python2.6 -DNDEBUG   mod_wsgi.c -L/usr/local/lib -L/usr/local/lib/python2.6/config  -lpython2.6 -lpthread -ldl  -lutil -lm
/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing  -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -I/usr/local/include/python2.6 -DNDEBUG  -c -o mod_wsgi.lo mod_wsgi.c && touch mod_wsgi.slo
sh: /apr-1/build/libtool: No such file or directory
apxs:Error: Command failed with rc=8323072
.
make: *** [mod_wsgi.la] Error 1

mod_wsgi 3.2 Apache 2.2 Python 2.6 apr-1.2.7-11

Is this error because of a missing package.. or else how do I solve this issue?

share|improve this question
add comment

1 Answer

Do you have a libtool package installed?

rpm -qa libtool*

By the way: Instead of compiling yourself, consider using a relevant package from the IUS Community Project repository.

share|improve this answer
    
libtool is already here in the system..libtool-1.5.22-7 –  MMRUSer Apr 12 '10 at 3:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.