Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an OpenBSD box running Python 2.6. I want to install py-setuptools, but that package is built against 2.5.

I was curious as to what the Makefile for py-setuptools looks like, to see if it mentioned anything about Python 2.5 as a dependency. I did not find anything version-dependent.

I typed make install in /usr/ports/devel/py-setuptools on a whim, and it blew up because of failed missing Python 2.5 dependency. That is expected.

My question is, How do I modify the Makefile to build against Python 2.6 ?

I came across this in the man pages, but I am still clueless how to specify what version to build against. Also, I don't see anything that actually installs the egg.

share|improve this question
add comment

2 Answers 2

Try removing the MODULES= lang/python line near the bottom of the Makefile.

share|improve this answer
    
Just curious, is it ok to modify a Makefile in the ports tree? Is that behavior frowned upon? –  The_dude_man Apr 12 '10 at 18:50
    
You might want to make a quick backup copy, but yes. The worst it's going to do is not work, which is what the backup copy is for. Or you can always just DL a new copy from CVS. –  Chris S Apr 12 '10 at 18:53
add comment

Ye almighty MODPY_VERSION= 2.6

Dont know how I missed that the first time...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.