Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sorry about the title, dont' really know what it should be.

If I open a doc in read only mode I'm able to press save and then it opens up a save as box and the default directory is the directory on the sharepoint server and if you press save you save it to the server.

This actually makes the whole process not really "read only" mode since I could actually update the document.

Is there a way to prevent this from happening so that if someone chooses read only there is no way possible to updload any changes back to the sharepoint site?

Also, it has been suggested as a solution to get rid of the edit/read only option so that people have to check out the document. Is there a way to remove the edit/read only option on documents?

share|improve this question

To prevent editing of the document, you'll need to either manage the permissions of the document, or the entire library, so that only a select group have the Contribute or Full Control permissions. You will need to break permission inheritance to specify custom permissions on the library.

To force check out of the document for editors, go to the library settings and choose Versioning Settings, then tick "Require documents to be checked out before they can be edited?". Users will then be prompted to open the document as "Read Only" or to "Check Out and Edit".

share|improve this answer

It could also be related to your Windows version being 64 bits and Internet Explorer.

If you work with the x64 version of IE, you don't get the prompt to have the document opened in read-only or edit mode. (Internet Explorer 9). Navigate to program files(x86)\Internet epxlorer. Open the iexplore.exe there instead and navigate to the same library and try to oen the document to see if you get the prompt to either open in read or edit mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.