Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I had already installed the yum-security before. And I was going to do an update by entering the following command:

[root@localhost /]# yum update
Loaded plugins: presto, priorities, refresh-packagekit, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package eject.i686 0:2.1.5-17.fc12 set to be updated
---> Package glibc.i686 0:2.11.1-4 set to be updated
---> Package glibc-common.i686 0:2.11.1-4 set to be updated
---> Package glibc-devel.i686 0:2.11.1-4 set to be updated
---> Package glibc-headers.i686 0:2.11.1-4 set to be updated
---> Package gnome-themes.noarch 0:2.28.1-3.fc12 set to be updated
---> Package gtk2.i686 0:2.18.9-3.fc12 set to be updated
---> Package gtk2-immodule-xim.i686 0:2.18.9-3.fc12 set to be updated
---> Package kernel-PAE.i686 0: set to be installed
---> Package kernel-PAE-devel.i686 0: set to be installed
---> Package kernel-PAEdebug-devel.i686 0: set to be installed
---> Package kernel-debug-devel.i686 0: set to be installed
---> Package kernel-devel.i686 0: set to be installed
---> Package kernel-firmware.noarch 0: set to be updated
---> Package kernel-headers.i686 0: set to be updated
---> Package libnetfilter_conntrack.i686 0:0.0.101-1.fc12 set to be updated
---> Package media-player-info.noarch 0:5-1.fc12 set to be updated
---> Package nscd.i686 0:2.11.1-4 set to be updated
---> Package perf.noarch 0: set to be updated
---> Package rhythmbox.i686 0:0.12.6-5.fc12 set to be updated
---> Package sysvinit-tools.i686 0:2.87-3.dsf.fc12 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel-PAE.i686 0: set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

 Package                  Arch     Version                     Repository  Size
 kernel-PAE               i686           updates     20 M
 kernel-PAE-devel         i686           updates    6.2 M
 kernel-PAEdebug-devel    i686           updates    6.2 M
 kernel-debug-devel       i686           updates    6.2 M
 kernel-devel             i686           updates    6.1 M
 eject                    i686     2.1.5-17.fc12               updates     49 k
 glibc                    i686     2.11.1-4                    updates    4.2 M
 glibc-common             i686     2.11.1-4                    updates     14 M
 glibc-devel              i686     2.11.1-4                    updates    953 k
 glibc-headers            i686     2.11.1-4                    updates    590 k
 gnome-themes             noarch   2.28.1-3.fc12               updates    1.5 M
 gtk2                     i686     2.18.9-3.fc12               updates    3.2 M
 gtk2-immodule-xim        i686     2.18.9-3.fc12               updates     60 k
 kernel-firmware          noarch           updates    968 k
 kernel-headers           i686           updates    749 k
 libnetfilter_conntrack   i686     0.0.101-1.fc12              updates     37 k
 media-player-info        noarch   5-1.fc12                    updates     32 k
 nscd                     i686     2.11.1-4                    updates    189 k
 perf                     noarch           updates     79 k
 rhythmbox                i686     0.12.6-5.fc12               updates    4.0 M
 sysvinit-tools           i686     2.87-3.dsf.fc12             updates     58 k
 kernel-PAE               i686      @updates    72 M

Transaction Summary
Install       5 Package(s)
Upgrade      16 Package(s)
Remove        1 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)

Total download size: 75 M
Is this ok [y/N]:

But then I changed my mind, I decided to do a security-only update instead of a full update, so I entered the following command:

[root@localhost /]# yum --security update
Loaded plugins: presto, priorities, refresh-packagekit, security
Setting up Update Process
Resolving Dependencies
Limiting packages to security relevant ones
http://download.fedoraproject.org/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.cuhk.edu.hk/pub/linux/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.cuhk.edu.hk/pub/linux/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.cuhk.edu.hk/pub/linux/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.riken.jp/Linux/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.riken.jp/Linux/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://mirror.cse.iitk.ac.in/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://mirror.cse.iitk.ac.in/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://mirrors.isu.net.sa/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://mirrors.isu.net.sa/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
ftp://ftp.chu.edu.tw/linux/Fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://mirror.yandex.ru/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://mirror.yandex.ru/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://linus.iyte.edu.tr/linux/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://linus.iyte.edu.tr/linux/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.jaist.ac.jp/pub/Linux/Fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.jaist.ac.jp/pub/Linux/Fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.kddilabs.jp/Linux/packages/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://srv2.ftp.ne.jp/Linux/packages/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://www.ftp.ne.jp/Linux/distributions/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://srv2.ftp.ne.jp/Linux/distributions/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.rhd.ru/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.rhd.ru/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://mirrors.163.com/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://mirrors.163.com/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://mirror.nus.edu.sg/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://mirror.nus.edu.sg/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.yz.yamagata-u.ac.jp/pub/linux/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.yz.yamagata-u.ac.jp/pub/linux/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.linux.org.tr/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.linux.org.tr/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://mirrors.cytanet.com.cy/linux/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://mirrors.cytanet.com.cy/linux/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://fedoramirror.hnsdc.com/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://fedoramirror.hnsdc.com/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.twaren.net/Linux/Fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://c147.twaren.net/pub/Linux/Fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.mirror.tw/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.mirror.tw/pub/fedora/linux/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ftp.cs.pu.edu.tw/Linux/Fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ftp.cs.pu.edu.tw/Linux/Fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
http://ubuntu.cn99.com/fedora/updates/12/i386/repodata/updateinfo.xml.gz: [Errno 14] HTTP Error 416 : http://ubuntu.cn99.com/fedora/updates/12/i386/repodata/updateinfo.xml.gz 
Trying other mirror.
Error: failure: repodata/updateinfo.xml.gz from updates: [Errno 256] No more mirrors to try.
 You could try using --skip-broken to work around the problem    

^C[root@localhost /]#

As it can be seen in the output, when I run the yum --security update command, it did show the Limiting packages to security relevant ones message so it's aware of the option.

But I don't know why it keeps reporting the http error 416. I searched in google and found the following description of the error but it doesn't seem to help much.

HTTP ERROR 416 - Requested Range Not Satisfiable
A 416 status code indicates that the server was unable to fulfill the request. This may be, for example, because the client asked for the 800th-900th bytes of a document, but the document was only 200 bytes long.

It suggests me to use the --skip-broken option, I tried and the output is the same.

I already tested many times, it just doesn't work when the --security option is used.

What could be the possible cause for this problem?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Sounds like it's trying to pull only the security data from the repo servers, but is failing. Run yum clean metadata and try again.

share|improve this answer
It's amazing. Thank you very much for your solution. Now it works! –  bobo Apr 13 '10 at 1:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.