Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I did download RubyStack 2.0.3 for VMWare (Ubuntu 9.10) but I cannot download anything on it! It appears that all basic utilities are missing/screwed:

bitnami@linux:/var/tmp$ wget
-bash: wget: command not found

bitnami@linux:/var/tmp$ curl
curl: error while loading shared libraries: libcurl.so.4: cannot open shared obj
ect file: No such file or directory

bitnami@linux:/var/tmp$ man wget
-bash: man: command not found

bitnami@linux:/var/tmp$ sudo apt-get install wget
[sudo] password for bitnami:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Couldn’t find package wget

Any ideas how can I download anything on this machine? (I don't have physical access to it)

UPDATE

You gotta be kidding me...

bitnami@linux:~$ ftp
-bash: ftp: command not found

bitnami@linux:~$ smbclient
-bash: smbclient: command not found
share|improve this question
    
I've had fun with this sort of thing before. I've had firewall appliances that didn't come with GCC or even Make (smoothwall, anyone) so that doing anything out of the ordinary was more trouble than it was worth. Good luck! –  Mark Henderson Apr 13 '10 at 2:42
    
How on earth somebody can survive without wget? <g> –  Winluser Apr 13 '10 at 2:46
1  
BTW (and completely off-topic): Do you know pfSense? It rocks! ;) –  Winluser Apr 13 '10 at 2:47
    
Are your apt repos set up correctly? It's configured in /etc/apt/sources.list. More details are here: help.ubuntu.com/community/Repositories/CommandLine –  tekhammer Apr 13 '10 at 2:49
1  
@Winluser, yes we decided to deploy on pfSense. I had those issues when we were evaluating all the options that were in the marketplace. We're very, very, very happy with pfSense (especially since v2.0 has fixed ALL of the issues we had with 1.2) –  Mark Henderson Apr 13 '10 at 3:00

3 Answers 3

up vote 4 down vote accepted

I use debian, not ubuntu, but, the method should be the same

First, try:

sudo bash
apt-get update
apt-get -f install
apt-get install wget

Barring that,

cat /etc/apt/sources.list

Make note of the url prefix after deb

apt-cache show wget

look for:

Filename: pool/main/w/wget/wget_1.12-1.1_i386.deb

grab that in your local browser assembling the url portion from /etc/apt/sources.list and the filename portion from apt-cache show. scp the file to your machine,

dpkg -i wget_whatever.deb

If /etc/apt/sources.list is not set up correctly, try tekhammer's suggestion and then rerun apt-get update.

share|improve this answer
    
THANK YOU, man! I luv'ya! Your first 'apt-get -f' did the trick! Now I have wget! :) –  Winluser Apr 13 '10 at 2:59

As cd34 mentioned, you need to use the package manager to install those utilities. It is a 'feature' as we try to make the appliances as lightweight as possible. We probably should document it better. Hope you enjoy Bitnami!

share|improve this answer

I'm using ubuntu 12.04 and I just had the same issue where sh and bash scripts where showing command wget not found. The solution for me turned out to be just put the full path to wget like so:

/usr/bin/wget "http://my-url-here"

instead of

wget "http://my-url-here"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.