Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to set up a UNC share for my hosted dedicated server to access a share on itself. Unfortunately TFS requires a UNC share.

I am on a Windows Server 2008 Standard SP2 64bit dedicated server behind a PIX 501 firewall hosted with GoDaddy.

I just cannot get the server to access itself and get this error:

Windows cannot access \\SERVER\SHARE Check the spelling of the name.. etc.

I've found numerous questions about this but no answer to my problem.

  • Server 2008 Standard x64 SP2
  • Workgroup - not domain
  • Windows Firewall is off
  • Computer browser service is on
  • I am trying to access \\MYMACHINE\TFS-BUILDS by typing in - or double clicking. Neither works.
  • Machine has single network card
  • Filesharing wizard says share was ok
  • Share was showing under 'Computer management'
  • Permissions are set to 'everyone' full control
  • No obvious errors in eventlog
  • Reboot didn't fix it
  • Unfortunately I cannot try to access other shares in or out of this machine because it is a hosted dedicated server and the only machine behind a hardware firewall.

The only thing left i can think of is that the hardware firewall needs to be configured. I don't think it is this because we have a 2003 Server machine behind a different hardware firewall and that one works fine.

What on earth is left?!

share|improve this question
    
What happens if you try to access the machine via it's IP address? –  Ben Quick Apr 13 '10 at 10:28
    
@ben doesn't work :(. also tried adding hostname to my hosts file –  Simon Apr 13 '10 at 10:59
    
found this monster list of sharing issues. not found an answer yet. kadaitcha.cx/file_sharing.html –  Simon Apr 13 '10 at 11:00
add comment

2 Answers

OK I got it!

Apparently 'File and printer Sharing for Microsoft Networks' is not installed for the network adapter by default. I'm not sure if this is a Windows 2008 default or the network card's default.

Here's what fixed it:

  • Right click on 'Local Area Connection'
  • Verify that 'File and Printer Sharing for Microsoft Networks' is NOT there
  • Assuming you don't see it - Click 'Install'
  • Double click on 'Service'
  • Select 'File and Printer Sharing for Microsoft Networks'
  • Click OK to install it
  • Reboot machine

You should be able to see it now. Jees! (Answer from http://kadaitcha.cx/file_sharing.html)

share|improve this answer
    
Hmmm.... I'm having the same problem with every one of our new Server 2008 systems and all of them have the 'File and Printer Sharing for Microsoft Networks' binding enabled on their only NIC. I can access the same share from another location, just can't access a share on the system I'm currently on. Which is too bad, because I use that trick to create Run-From-Anywhere shortcuts. –  Nathan Hartley Dec 20 '12 at 3:10
    
Best answer and to the point. I was going nuts from last 2 hours. –  Mandeep Janjua Mar 30 at 2:38
add comment

When trying to access administrative shares such as \\servername\c$ you may need to set a registry key - yes really!

This is what Microsoft calls 'UAC remote restrictions'

> Key:
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
> Value: LocalAccountTokenFilterPolicy 
> Data: 1 (to disable, 0 enables filtering)
> Type: REG_DWORD (32-bit)

See http://helgeklein.com/blog/2011/08/access-denied-trying-to-connect-to-administrative-shares-on-windows-7/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.