Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After some time of running fine, one of our Windows XP SP3 machines does not open some(!) new TCP/IP connections anymore.

Putty says Network Error: no buffer space available, IE won't open any new connections but e.g. network drive mappings still work, even new ones can be established.

netstat does not show more open connections that usual, ping and DNS lookups work fine.

Any hints?

share|improve this question
Google photo backups was the culprit in my case. Killed that process and the problem was immediately resolved. – davidparks21 Oct 19 '15 at 19:03

This can happen because of just about any piece of software that incorrectly holds network buffers without releasing them. It just happened to me in Win7 64bit. Chrome and Firefox stopped being able to connect to any web pages, windows file sharing stopped working, and WinSCP and PuTTY both gave errors that included the words No buffer space available. Oddly, Ubuntu 10 running under VirtualBox seemed to have no problem making new network connections - maybe it holds a number of network buffers in reserve.

To find out what software is leaking network buffers, you need to close programs until the problem goes away. So I started closing programs and trying the WinSCP connection after each program I closed, but the error persisted. Once I'd closed every visible program, I opened Windows Task Manager with Ctrl-Shift-Esc and started killing invisible programs with the End Process button. Be careful - killing some things the system relies on can cause problems, so don't kill anything you don't recognize without researching what that thing is. To help identify what things are, go to View > Select Columns and choose to show Image Path Name and Command Line. In general, be cautious about killing anything with a Command Line that begins with C:\Windows\ and be even more cautious before killing anything that begins with C:\Windows\System or C:\Windows\System32.

Killing C:\Windows\explorer.exe is fairly safe and can sometimes solve problems. For example, the extensions that generate thumbnails for third-party file types often cause problems, although not likely network-buffer-holding problems unless you've installed trojan extensions sending data back to some malicious server. Killing C:\Windows\explorer.exe will make your taskbar disappear along with all your file explorer windows. To get them back, go to File > New Task (Run...) and type explorer in the box that will appear, then click OK.

Keep ending programs until your problem is fixed and the last program you ended is likely the culprit. Sometimes ending a program will release a few network buffers that the program was legitimately holding, which may be enough to allow you to make a few successful network connections in another program using those few released network buffers. Therefore, you should double check that the problem is really solved by opening a lot of web pages or other connections at the same time.

In my case, killing fmsib.exe (part of FileMaker Server 13) let me make one new connection, but no more. Killing fmshelper.exe (also part of FileMaker Server 13) let me make dozens of additional connections, so I think it was the culprit, but that's only in my case.

share|improve this answer
I had been troubled by this for some time -- all of a sudden my browsers lost connectivity. I didn't realize it was a buffer leak until I tried doing an SSH and received an error message that brought me to this thread. Thanks a lot. – yclian Sep 6 '15 at 4:54

Have seen this issue in the past on Win98. It was resolved by adding a key to the registry "MaxConnections" to override the default buffer size.

Looking for a fix for XP the following may help:


An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full.

Start Registry Editor.

Locate the following subkey in the registry, and then click Parameters:


On the Edit menu, click New, and then add the following registry entry:

Value Name: MaxUserPort

Value Type: DWORD

Value data: 65534

Valid Range: 5000-65534 (decimal)

Default: 0x1388 (5000 decimal)


Sorry if it doesn't help.

share|improve this answer

I recently install the kleopatra Outlook GPG plugin which was eating all the resources and due to this I am also getting same error. By removing that plugin everything working smoothly.

share|improve this answer

Same experience here. In fact AFTER the error occurs, if you shut down Klepatra, the "no buffer space" error would go away.

share|improve this answer

Installed service-pack 3? You want to remove/disable services and background apps one at a time to eliminate the one which is leaking connections. This is going to be an application that makes a connection but gets slow responses from the remote host. I would look at the internet connection (I assume LAN or WAN) external link speed and would not mess with the antivirus - its not there, its more likely another application that's at fault. I would start with internet browsers and other remote connection using programs.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.