Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reason I can't get DTA to connect to my development machine. It connects to a remote DB just fine but when I point it to my dev machine I get an error saying:

Failed to initialize MSDB database for tuning (exit code: -1073741819).

I'm pretty sure it's not a permissions issue since I've used profiler to capture what it's doing and all of the commands it's run so far look fine and are being run under my account which is associated with the sysadmin role, when I run them in sql management studio they go through fine. I'm pretty convinced that the problem is related to creating the objects in MSDB that are used by DTA but I tried creating these manually (I found scripts on the web) and it just seems to push the problem along the line slightly.

I'm going out of my mind - have even tried reinstalling SQL but that's not fixed it.

I'm using SQL 2008 with SP1 (10.0.2531) on windows server 2008 (patched up to date).

SAVE ME!!!!!

share|improve this question
    
did you re-create msdb when you re-installed? –  Nick Kavadias Apr 14 '10 at 14:48
    
Yup, I uninstalled and re-installed all of SQL - I was getting pretty desperate! –  Andrew Hancox Apr 15 '10 at 9:23
    
is your account using windows or sql authentication, and are you connected to your domain? i have seen issues with certain parts of SQL 2008 where i am running locally, not connected to a network, and get authentication issues. –  SQLRockstar May 6 '10 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.