Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Saving an Excel or Word 2007 file to a network share is very slow in Office 2007. It might take as long as two minutes two save a 100kb file. What could be causing this?

The network share is hosted on a Windows 2003 server.

share|improve this question
1  
Should be moved to SuperUser. – gravyface Apr 13 '10 at 17:46
4  
why? this is client/server – jao Apr 13 '10 at 19:46
up vote 2 down vote accepted

I am going to assume your network connection is just fine, and you are local to the server (i.e not VPN'ing in). You didn't specify whether this was just yourself, or everybody having the issue, however that is pretty irrelevant to my answer.

I've seen Office hang for a while on save and/or print dialog boxes when you have either a network printer which is no longer in service, or mapped network drives pointing to non-existent/unavailable servers.

Is it just Office which is slow to save, or any application? Try opening Notepad and attempting to save to the same file server. Also, when doing a \\SERVERNAME, can you browse the share(s) relatively quickly?

If you have physical access to the server or can RDP to it, fire up Task Manager and check you've not got something eating away all of the CPU. While you're in Task Manager, check the memory usage isn't excessive too.

share|improve this answer
    
It's just Office, and it is me and at least two other persons running Windows 7. There's no high CPU or Mem load on the server. All mapped network drives are connected to existing and available servers – jao Apr 13 '10 at 19:46

This worked for me when office was slow to launch and save:

Make the default printer Adobe PDF or a locally attached printer instead of a network printer.

share|improve this answer

I did some research and this is what I found on different forums:

There are two possibilities:

  1. slow Office save times to Windows Server 2008

Vitaly suggested to disable SMB2 on the server that holds the share. To do so add a REG_DWORD entry named Smb2 with a value of 0 to: HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

Then reboot the server.

SMB2 is and updated version of SMB1 protocol. SMB2 is native to Server 2008 and Windows 7 and Vista. If any of your clients would be XP, OR your server would be W2K3, then SMB1 would be used instead and you would not have the problem you are experiencing right now. Disabling SMB2 on the W2K8 server forces Windows 7 to become backward compatible and switch to using SMB1. However, the problem you are experiencing is caused by MS Office 2007 is not working properly with SMB2 protocol. Since I am not a developer and I do not work for Microsoft I can not tell you why Office 2007 works this way with SMB2. For testing purposes, you can try to search for how to disable SMB2 on your Windows 7 client rather then disabling it on the server. This should provide same result. I know that disabling something may not be the prettiest solution but this is the only one that worked for this problem so far.

  1. slow Office save times to Windows Server 2003

Clay Kimber suggested to try disabling indexing on the file locations where you are experiencing slow save times. Try disabling indexing of Offline Files if appropriate for your situation: https://technet.microsoft.com/en-us/library/gg985445(office.12).aspx

James Nelson added to that: SMB2 doesn't exist in Windows Server 2003. The cause may be an offline files cache that was being indexed by Windows 7. Please disable indexing on the offline files cache.

If you are seeing this with Windows 7 and Win 2003 file server with redirection in place, I have to suggest that the offline files cache on Windows 7 may be the issue. Have a look in your users' folders on the server and look for temp files. If you see a bunch of odd looking temp files with alpha-numeric characters in their names, run a test by disabling indexing on the user's offline files cache in Indexing Options in the Control Panel.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.