Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running postfix on a debian lenny system. sending mail in general works without any problems. however some recipent mail systems return an error and I can't get a clue what is causing the problem. So far I suspect that this is either postfix setup itself or the reverse dns resolution.

The mail server is running on a virtual server from my service provider.

running the command hostname is returning my.domain however running host <ip-address> is returning some alias from the virtual server system. now i'm not quite sure if that is causing my problem????

The mail system

<recipient-mail>: host mx0.recipient.domain[xxx.xxx.xxx.xxx] refused to talk to me:
550 Forged HELO: you are not my.domain

Reporting-MTA: dns; my.domain
X-Postfix-Queue-ID: 6A1135B08002
X-Postfix-Sender: rfc822; name@my.domain
Arrival-Date: Tue, 13 Apr 2010 17:50:36 +0200 (CEST)

Final-Recipient: rfc822; recipient-mail
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx0.recipient.domain
Diagnostic-Code: smtp; 550 Forged HELO: you are not my.domain
share|improve this question

2 Answers 2

up vote 0 down vote accepted

This might be an issue with your HELO/Reverse DNS. Take this Email Server Test and follow its recommendations.

share|improve this answer
    
The Email Server Test is giving me an OK for reverse DNS. Anyway that link was pretty helpful. I suspect that it is the recipients setup as well that is troubling! –  Martin Ahrer Apr 17 '10 at 14:54

Change the value of myhostname in your Postfix configuration (main.cf) to the value of the reverse record for your IP address (what you call 'some alias from the virtual server system'). Or ask your virtual server provider to change the PTR record, note that this information can be cached in the DNS system and can take some time to get updated around the world.

I think it's better to stick with just one hostname, using different ones in all kind of configuration files can cause problems like this one. In this case it's a anti-spam rule to check if you really are who you say you are.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.