Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can't figure out how to fix this, apparently ruby doesn't like anything in my home directory.

/Users/Connor/.rvm/rubies/ree-1.8.7-2010.01/bin/gem:4: warning: Insecure world writable dir /Users/Connor/.rvm/rubies/ree-1.8.7-2010.01/bin in PATH, mode 040766

How can I fix this?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

chmod -R o-w ~/.rvm

share|improve this answer
    
Translated for folks that don't do octal: remove the world-write bit. –  Avery Payne Apr 5 '12 at 1:26

Note that this is just a warning, and Ruby should still run even with this Warning message.

It appears that /Users/Connor/.rvm/rubies/ree-1.8.7-2010.01/bin has permissions 766, which probably looks like this:

drwxrw-rw- 2 connor yourgroup 68 Apr 13 14:03 bin

This is not secure, because it means anyone with access to your system could install files under /Users/Connor/.rvm/rubies/ree-1.8.7-2010.01/bin, and you might execute those unknown files by accident.

Run this command from the commandline:

chmod go-rw /Users/Connor/.rvm/rubies/ree-1.8.7-2010.01/bin

This will disallow anyone but you from writing to and reading from that directory.

share|improve this answer

Your umask settings are likely improperly set, enabling files to be created with less than secure settings.

The other solutions posted were about fixing the permissions issue, but not fixing the umask issue that is likely a part of it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.