Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I reboot a Windows 2003 or Windows 2008 server via a Remote Desktop connection, the server comes back up and will not accept any RDP connections: the RDP client errors out with "Connection Refused."

The Terminal Services service is running on the server and restarting it has no effect. No errors are logged on the server.

The only way I've found to fix this is to login at the console or via the DRAC and reboot the machine again, which is an ugly solution for obvious reasons.

Has anyone run into this before?

share|improve this question
    
i just got into this superuser.com/questions/132509/… –  Magnetic_dud Apr 19 '10 at 11:05
add comment

3 Answers

up vote 3 down vote accepted

Yes, I've run into it on several different servers. Two workarounds have been reliable for me, 1) always use the /admin option of mstsc when starting the session that will initiate the reboot, or 2) use the shutdown command from another server to do the reboot.

share|improve this answer
1  
The /admin flag seems to work for me. –  sh-beta Apr 20 '10 at 15:08
    
thanks. this answer saved me! –  djangofan Apr 7 '11 at 22:36
add comment

Does the server have multiple NICs? I've had similar issues when terminal services service binds to the wrong one. If that's case, see http://serverfault.com/questions/49428/rdp-remote-desktop-disconnected-error-2308-socket-closed

share|improve this answer
    
I've seen this on multi-NIC and single-NIC machines. –  sh-beta Apr 15 '10 at 13:38
    
that does not fix the problem to me –  Magnetic_dud Apr 19 '10 at 11:20
add comment

EDIT - didnt read the entire question before submitting answer.

Have you tried resetting the terminal services session remotely?

at Command Prompt, type qwinsta /server:196.34.56.78

It will give you the following result:

SESSIONNAME USERNAME    ID  STATE   TYPE
console     0   Conn    wdcon
rdp-tcp     65536   Listen  rdpwd
rdp-tcp#8   Administrator   7   Active  rdpwd
rdp-tcp#9   Internet    8   Active  rdpwd

Choose the ID of the session that you would like to end and type: rwinsta /server:196.34.56.78 8

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.