Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having some issues with networking on a new Linux server I'm building. The OS is SLES 11. When booting into runlevel 1, I see that eth0 is showing an IP. Physically, there is a network cable plugged into the card associated with eth1, and then there is a network cable plugged into a QLogic iSCSI card (eth4, not shown). I've been troubleshooting this for awhile, and it seems like eth0 is somehow getting assigned an IP, even though it isn't configured in Linux or even plugged into the network for that matter. Thoughts?

ifconfig -a

Here is the ifconfig output

(Sorry, I need more rep before I can post images on SF...)

share|improve this question
    
Not sure it is true on SUSE, but on other distros networking is started for all run levels. But no server daemons are started. Not sure why you would be getting an address if none was configured and there was no connectivity though. –  Zoredache Apr 14 '10 at 18:16
    
@Zoredache: Which distros have you seen that had networking enabled for runlevels 1 and 2? I've not come across any like that. –  Ignacio Vazquez-Abrams Apr 14 '10 at 18:19
    
@Ignacio Vazquez-Abrams: On both Debian/Ubuntu and derivatives Networking is enabled all runlevels. Also they normally operation is done at runlevel 2. –  Zoredache Apr 14 '10 at 18:32
    
Thx for the replies. I'm going to rebuild SLES on it again and cross my fingers that it's not a bad NIC card (which is built into the motherboard). The server is a SUN x4140. –  Banjer Apr 14 '10 at 18:33
    
@Satanicpuppy: No luck in runlevel 2. –  Banjer Apr 14 '10 at 19:41

1 Answer 1

up vote 0 down vote accepted

The runlevels are completely configurable from your inittab, so it's possible that runlevel 1 is mapped to a mode with networking activated.

Does look odd though. Try booting into runlevel 2: in Suse that should default to multiuser/no networking.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.