Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I’m hoping you would be able to help me out with this little problem I’m having.

I installed DPM 2010 in our test environment to test backups on Exchange 2010 servers.

The environment includes :

1xDC

2x Exchange Server 2010

1x DPM 2010 server

All of these are running on Microsoft server 2008 R2 Virtual machines. The host machines are using Hyper-v.

So the problem goes like this :

1- I tried to install the agents from the DPM server GUI, which failed saying I didn’t have the correct permissions.

2- So then I tried the manual installation using the commands from : the Microsoft site http://technet.microsoft.com/en-us/library/bb870935.aspx

3- The agent installation worked but when I get to attaching the agents to the DPM server it still gives me the error saying that the specified account does not have administrator rights.

4- I tried the Domain admin, users who are domain admin + local admin, single local admins.

5- I have turned off the windows firewall and made sure all the services are running.

So now I’m out of ideas and really need help, the agent attach to the DPM server is the last thing that is holding me back from deploying everything to the production site. Any help would be really appreciated.

share|improve this question

2 Answers 2

It's been a little while since I've setup DPM, try this one:
Run winrm quickconfig from an elevated command prompt on the servers with the agents.

share|improve this answer
    
There is failure while attaching production server C:\Program Files\Microsoft DPM\DPM\bin\Attach-ProductionServer.ps1 : Unable to configure security settings for MBX1 on the computer AREA51DPM. At line:1 char:30 + .\Attach-ProductionServer.ps1 <<<< + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep tion + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio n,Attach-ProductionServer.ps1 Make sure that the user name and password you have provided has administrator pr ivileges on the target computer. is what i get even after the winrm –  Michael Apr 15 '10 at 18:20
    
You're running the command from the DPM PowerShell (The shortcut in the Start Menu under MS DPM), correct? Not from the standard Windows PowerShell. –  Chris S Apr 15 '10 at 19:45
    
Yes i am running the command from the DPM PowerShell. I've been looking more into it and the base problem seems to be that the selected Agent servers are not being added to the MSDPMTrustedMachines group on the DPM server. I tried doing that mannually too but i get an error saying that "A member could not be added to or removed from the local group because the member does not exist." Which is weird and not accurate because I am able to find them but it will not let me apply the settings. –  Michael Apr 16 '10 at 13:17

Here is a link to troubleshoot Agent install issues. It might cover what you're experiencing : http://technet.microsoft.com/en-us/library/bb808878.aspx. I would also check the COM and DCOM security settings.

share|improve this answer
    
The error i get is not on that list, i checked the com and dcom though. Attach protected computer MBX1.area51.com failed: Error 274: Unable to configure security settings for MBX1 on the computer AREA51DPM. Recommended action: Make sure that the user name and password you have provided has administrator privileges on the target computer. –  Michael Apr 15 '10 at 19:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.