Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get xdebug working on my snow leopard box.

It uses port 9000.

When I ask slickedit to monitor this port is gives an error that the address is not available.

I've gone to canyouseeme.org to see if the port is open.

It says the port is NOT open.

I've verified that I have that port forwarding to my box from the router and i do NOT have the mac firewall running.

I'm stumped. Any ideas?

share|improve this question

4 Answers 4

up vote 4 down vote accepted

You can also see if it anything is listening on port 9000 by typing netstat -an |grep 9000 |grep LISTEN in Terminal. Here is an example on my system, looking for 22 instead of 9000:

jed@jed-mbp:~$ netstat -an |grep 22 |grep LISTEN
tcp4       0      0  *.22                   *.*                    LISTEN
tcp6       0      0  *.22                   *.*                    LISTEN

This means that my system is listening on 22 for connections both on IPv4 and IPv6.

Good luck,

--jed

share|improve this answer

If you need to quickly scan a Mac via command line, use the stroke command, which is located on all Macs in /Applications/Utilities/Network\ Utility.app/Contents/Resources.

The syntax is: stoke host startPort endPort

For example,

[root@my-cumulus 17:36:46 ~]# stroke 192.168.90.3 0 9287
Port Scanning host: 192.168.90.3

Open TCP Port:  22      ssh
Open TCP Port:  80      http
Open TCP Port:  311     asip-webadmin
Open TCP Port:  625     dec_dlm
Open TCP Port:  3283    net-assistant
Open TCP Port:  5900    vnc-server
Open TCP Port:  8009
Open TCP Port:  8954    cumulus-admin
Open TCP Port:  9287    cumulus
share|improve this answer

can you open the Terminal and telnet <YOUR MAC'S ADDRESS> 9000 ?

share|improve this answer
    
Nope.... [~/Public/Source/dst2/dst] telnet 127.0.0.1 9000 Trying 127.0.0.1... telnet: connect to address 127.0.0.1: Connection refused telnet: Unable to connect to remote host –  GeoffreyF67 Apr 15 '10 at 23:45
    
Actually, yes it does work ok. I didn't have the ide running with xdebug when I just tried it. ran the ide and tried again and it worked... –  GeoffreyF67 Apr 15 '10 at 23:47

Same problem here, i gave after a few hours, juts re-configure xdebug to run on port 9001 and you will be fine. OSX doesn't like port 9000.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.