Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed SQL Server 2005 with Reporting Services on Windows 7 Ultimate x64 and when I try to configure it when clicking on "Windows Service Identity" I get this error message:

There was an error while switching panels. The most likely cause is an error retrieving WMI properties. The exception details are:

InvalidArgument=Value of '1' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex

Here is a screenshot: error message


EDIT:

This problem disappeared after I installed SP3 for SQL Server. I have problems on the next panes though.

Now on the Web Service Identity pane the ASP.net service account textbox is empty, I select classic app pool for both dropdowns -> click apply and I get an error "There was an error setting the identity for the web service. The previously set identity will be used." and the details:

ReportServicesConfigUI.WMIProvider.WMIProviderException: The account name is not valid. Specify an account in the form domain\alias.
   at ReportServicesConfigUI.WMIProvider.RSReportServerAdmin.SetWebServiceIdentity(String applicationPool)
share|improve this question
    
Details on the errors? –  Jason Cumberland Apr 16 '10 at 13:56
    
@Omu: are you running the config utility as an admin? –  MattB Apr 16 '10 at 13:58
    
@MattB no I wasn't running it as an admin but I have my UAC turned off anyway, I tried now running it as an admin, and it's the same thing –  Omu Apr 19 '10 at 6:53
    
@Jason Cumberland I've added the details –  Omu Apr 19 '10 at 6:59
add comment

3 Answers 3

Try setting up a new application pool (I'm assuming you had it use an existing one but I could be wrong.) and set the user to one of the predefined ones, I use Network Service for just about everything. If this is on a workstation that is not joined to a domain then the domain\username thing won't really work unless it's "workstationname\username" and you use a local account. Network Service is the safest route here. Also check to make sure that Network Service is set up to be in the local group named IIS_WPG on the workstation and that this user has full control on the report server and report manager directories.

share|improve this answer
add comment
up vote 1 down vote accepted

ok, I found the solution, all I had to do is:

on a clean Windows 7 Ultimate install,

  • install IIS with all the required components for reporting services
  • install sql server with reporting services (and don't start the configuration tool)
  • install SP3 for sql server
  • check for windows updates and install all of them than check again
  • run the config tool as an administator and everything is configured (green) already
share|improve this answer
add comment

Looks like someone else is experiencing this problem; have a look at some possible solutions here:

http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/7f57f1a0-3458-49b6-a0ff-820ba1385f6b

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.