Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to enable the FTP service in the preferences (File Sharing->Options->Share Files and Folders Using FTP) the check box enables and then disables again. The console is giving me the message :

16/04/2010 12:14:20 com.apple.coreservicesd[51] sh: launchctl: command not found

This indicates to me that it can't find the launchctl executable

launchctl is present in the folder /bin

/bin is set in the PATH variable for sh and bash shells and also in the ~/.MacOS/environment.plist

How can I fix this so that my preferences can find this so that I can enable the FTP service.

Edit: Following various suggestions, I have removed the environment.plist file from .MacOSX folder, run verify permissions / repair permissions from disk utility. I have created another administrator user and tried starting it for that user.

The permissions for launchproxy is:

-r-xr-xr-x   1 root  wheel    60032 25 Jul  2009 launchproxy

and running the command /usr/libexec/launchproxy ftpd -l -n gives me:

launchproxy[964]: launch_msg(CheckIn): Operation not permitted
share|improve this question

1 Answer 1

What are the permissions for /bin/launchctl, is it executable? I tried it quickly on my machine, and it works. It starts a process /usr/libexec/launchproxy ftpd -l -n. Maybe you should also check /usr/libexec/launchproxy's permissions.

I'm using Snow Leopard, which version are you using?

share|improve this answer
    
Using Snow Leopard too –  Xetius Apr 16 '10 at 13:15
    
Checked the permissions (updated main question) and still not working. Tried running the process directly (and with sudo) but still not working –  Xetius Apr 16 '10 at 13:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.