Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to provision a 2k8r2 Enterprise server in ESXi4. The OS installation goes fine, VMware tools, adding to domain, updates. All the basic stuff before you start adding Roles and Features.

I've had this happen on two attempts already, and I'm not sure where the problem might be. I don't think it's hardware, because I have another 2k8r2 Standard server that's running fine. The only real difference is the install media. The server that's working was installed using a trial ISO and license. The one I'm having problems with is a full MAK installation.

When I go to add a Role (the last case was Application Server) it gets all the way to "collecting installation results" before it hangs. CPU utilization in the vSphere client shows little spikes of activity with flatlines inbetween, but the whole console is locked up. The only way to release it is to power off and bring it back up. When you go to look at the added roles after bringing it back up, it shows that it is installed, but I don't trust that something didn't get wedged in all of that.

The first install I did was with Thin Disk provisioning. The second attempt was with regular disk provisioning. In both cases 4GB of RAM, 2 vCPUs.

VMware host is a HP Proliant DL380 G6, RAID-1 OS, RAID-5 data volume. 12 GB RAM.

Has anyone else had this problem, or know where I should start poking around?

share|improve this question
up vote 4 down vote accepted

Are you useing Update1 to ESXi4? Only since than 2k8R2 Servers are supported and I had the same problem. In my case it was only when operating from the console. Via RDp I never had a Problem. After Update1 the Console worked too.

share|improve this answer
RDP into the server worked. We're planning on going to Update 1 next – Holocryptic Apr 19 '10 at 22:14

There are known problems in the video driver for Windows Server 2008 R2. I've experienced similar problems with ESX 3.5.

Try using RDP; it's only the VM console that actually hangs.

share|improve this answer

This is a bug with VMware Tools and ESX 4. It's fixed in ESX 4.0 Update 1.

From the VMware knowledgebase:

The XPDM (SVGA) driver supplied by VMware tools is a legacy driver and is not supported on ESX 4.0 running Windows 7 and Windows 2008 R2 guest operating systems.

When using Windows 7 or Windows 2008 R2 as a guest operating system on ESX 4.0, do not use the SVGA drivers included with VMware Tools. Use the standard SVGA driver instead.

Another article referencing the problem:

share|improve this answer

I'm not so certain this is really fixed. Just installed update 2 and updated the tools. Same issue:

I’ve tried the WDDM driver (setting video memory to 32MB) – fixes the freezes but mouse performance still is not up to what I would expect (like the acceleration is broken)

The default VMware driver has great mouse performance but experiences these freezes.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.