Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I run configtest on our Apache server, I get the following:

`Syntax error on line 1023 of /www/conf/httpd.conf: 
Invalid command 'SSLEnable', perhaps mis-spelled or defined by a module not included in the server configuration`

I know this part of the configuration works. Is there a trick to make configtest mod_ssl aware?

EDIT: RHEL4, nonstandard Apache 1.3 install? I just wanted to fix the ssl access log format to where Webalizer can give a clearer picture on who's still using this thing before we take the thing down. Since it's going away, no point upgrading apache just for this side project.

share|improve this question

2 Answers 2

You get this error when mod_ssl is not loaded, because of this Apache doesn't know about the SSLEnable configuration directive. Make sure mod_ssl is installed and enabled in your configuration, you can get a list of modules by running httpd -M. If ssl_module is not listed you can install mod_ssl by running yum install mod_ssl (assuming RedHat EL is using yum as a package manager like CentOS).

share|improve this answer
    
With Apache 1.3 -M doesn't exist. You can still run -l to list compiled-in modules. –  Warner Apr 16 '10 at 20:16

If I understand correctly, you have mod_ssl installed and operational with the configuration but still receive an error when running configtest.

Are you using the apachectl appropriate to your installation? If you have a package installed and it compiled from source as well, you may be running apachectl with a binary that isn't mod_ssl aware.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.