Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two machines:

A: Win 2008 server B: Windows 7

They are on the same workgroup, and I enabled network discovery. So on the server, I have SQL Server installed with a SQL Server account (mixed mode is enabled). I'm trying to connect to this server from the win 7 machine in the workgroup, but no go. Do I have to reference the server by something else than machine name? How do I successfully establish that relation? I am a n00b to this type of thing...

Thanks.

share|improve this question
    
This was helpful: This was helpful: support.microsoft.com/kb/968872 –  Brian Mains Apr 21 '10 at 22:35
add comment

4 Answers 4

up vote 2 down vote accepted

Windows Server 2008 comes with the firewall blocking most stuff. Have you checked the server firewall to see if SQL is allowed? Ports 1433 and 1434 by default. You'll need 1434 on if you are using SQL Express and want to find it by browsing. Also check the SQL Server Configuration tool and see if TCP/IP is turned on.

share|improve this answer
    
OK, that's probably it, will double-check that. Thanks. –  Brian Mains Apr 21 '10 at 1:17
    
You can also turn off the firewall to see if you can connect, to determine that is the problem, but be sure to turn it back on as soon as you are done testing. –  Bratch Apr 21 '10 at 15:02
add comment

Use tcpview to get the port of sql express. Than, use "ip\instancename,port" to connect to the server. Verify firewall, but, it should work if both are in LAN. HTH

share|improve this answer
    
OK, will try... thankx. Not SQL Express... –  Brian Mains Apr 21 '10 at 0:54
    
Also, from the SQL Server Configuration Manager, SQL Server Network Configuration, Protocols for SERVERNAME, TCP/IP, Properties, IP Addresses tab, IP#, TCP Port (TCP Dynamic Ports if SQLEE). This config manager is also where you enable/disable protocols. –  Bratch Apr 21 '10 at 15:00
add comment

What version of SQL Server is it?

If it's express it'll install as a named instance - i.e. servername\instancename.

share|improve this answer
    
Got the name right, but no go... I don't think it's that. –  Brian Mains Apr 21 '10 at 0:59
    
In that case check for firewalls blocking access and also check with the SQL Surface Area Config wizard to make sure remote connections are actually allowed to the server. –  Chris W Apr 21 '10 at 7:52
add comment

So, what was the answer?

In order to access computers in workgroup you should manually creat the same account (same name, same password) on another computer (the same on both computers which are expected to communicate).

Also, I would have enabled tcp/ip on SQL Server (both in client tools and server) and made sure that common protocols are enabled, et., etc., ther are a lot of things to check.

share|improve this answer
    
Different accounts works fine for me. I ran the script I linked to above and enabled the port, and it works fine. –  Brian Mains Jul 14 '10 at 14:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.