Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having some issues getting apt to install trac correctly on my Ubuntu Jaunty Box.

Using the command 'apt-get install trac' I get the following output:

root@myserver:~# apt-get install trac
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  trac: Depends: python-setuptools (> 0.5) but it is not installable
        Depends: python-pysqlite2 (>= 2.3.2) but it is not going to be

installed Depends: python-subversion but it is not installable Depends: libjs-jquery but it is not installable Recommends: python-pygments (>= 0.6) but it is not installable or enscript but it is not installable Recommends: python-tz but it is not installable E: Broken packages

I have successfully used the command on my karmic kola desktop machine and am able to create new projects etc.

I thought I might be able to solve the problem by installing all python related extensions. This produced a very similar output.

I have Main, universe and multi-verse repositories enabled. Its a remote machine and I have no access to the gui.

Hope someone can help, googleing failed to solve the issue or find a solution!

Thanks,

Ben

share|improve this question

4 Answers 4

You could try to do the dangerous

apt-get update ; apt-get upgrade

to get all packages on the same version.

Tough maybe a install from source would be more safe: http://trac.edgewall.org/wiki/TracInstall

Jeroen

share|improve this answer

Have you tried using easy_install.

See the documentation http://trac.edgewall.org/wiki/TracInstall

share|improve this answer

Do you have more than one version of python installed on this system? I've seen similar problem reports where it turns out that the necessary modules are installed for one version of python, and the webserver is using a different version. This can happen with 32bit vs 64bit, or 2.4 vs 2.5, etc.

share|improve this answer

That sort of dependency breakage doesn't make sense. The versions that the error message is complaining about are available in Jaunty (e.g. version 0.6c9 of python-setuptools).

I would check /etc/apt/sources.list and /etc/apt/sources.list.d/*.list, and make sure that the same mirror is getting main, universe, and multiverse for jaunty, jaunty-security, and jaunty-updates.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.