Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

when I attempt to goto any page in my web application (i'm migrating the code from an asp.net web site to web application, and now testing it) .. i keep getting some not authenticated error(s) .

So, i've turned on FREB and this is what it says...

alt text

I'm not sure what that means?

Secondly, i've also made sure that my site (or at least the default document which has been setup to be default.aspx) has anonymous on and the rest off. Proof: -

C:\Windows\System32\inetsrv>appcmd list config "My Web App/default.aspx" -section:anonymousAuthentication
<system.webServer>
  <security>
    <authentication>
      <anonymousAuthentication enabled="true" userName="IUSR" />
    </authentication>
  </security>
</system.webServer>

C:\Windows\System32\inetsrv>appcmd list config "My Web App" -section:anonymousAuthentication
<system.webServer>
  <security>
    <authentication>
      <anonymousAuthentication enabled="true" userName="IUSR" />
    </authentication>
  </security>
</system.webServer>

Can someone please help?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

401.3 means that you're past the authentication phase, but access has been denied due to the ACL on the resource itself - in this case, possibly c:\users\blank\documents\visual studio 2008\projects\blank\webapplication1. This would not be unexpected, as typically IUSR would not have access to files underneath a user profile. Try moving (copying) the app underneath c:\inetpub instead.

share|improve this answer
    
kewl :) it was an ACL issue. cheers! –  Pure.Krome Apr 21 '10 at 4:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.