Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have WebLogic 11g installed on my machine under /srv/wls, and I start Node manager on it with /srv/wls/wlserver_10.3/server/bin/startNodeManager.sh.

I create my domain with config.sh, and then I want to start the Admin Server of that domain with Node Manager. So I open a WLST session and do the following:

> nmConnect(...)
> nmStart('AdminServer')

But when I then visit localhost:7001/console, and login, the screen on the browser remains blank and the server logs tell me the server has run out of PermGen space.

I don't encounter this problem when starting the Admin Server through the shell script under $DOMAIN/startWebLogic.sh. Then it works fine.

Any idea what I am doing wrong? I couldn't find anything in Google nor on the Oracle forums...

share|improve this question
add comment

1 Answer

The problem is that nmStart doesn't pass any arguments to the child JVM process and the defaults don't have enough memory. Try adding the following:

# Start the Admin Server
arg = "Arguments=\" -server -Xms192m -Xmx768m -XX:MaxPermSize=256m -Xrs\""
prps = makePropertiesObject (arg)
nmStart('AdminServer', props=prps)

This is an annoyingly common problem that Oracle/BEA seems to not want to fix or to document properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.