Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem when setting up Ubuntu Enterprise Cloud. When I use this command:-

euca-authorize default -P tcp -p 22 -s 0.0.0.0/0

The system says:-

EC2_ACCESS_KEY environment variable must be set.

Can anyone help me on this? How can I solve this problem?

Thank you.

Patrick

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I found this on a blog in some comments about setting up Ubuntu Enterprise Cloud:

Question:

I try to start a intance of the emi, but i got :

“EC2_ACCESS_KEY environment variable must be set”.

Can you help me with this ? Reply

Answer:

This is set in eucarc, the “. eucarc” should source the required env variables and set them for further commands.

Maybe this is usefull for you

share|improve this answer
    
Thank you Diskilla, but I don't know how to source the required env variables. Can you show me how to do it? Sorry, I'm quite new in this. Patrick –  Patrick Apr 20 '10 at 0:55
    
Hi Patrick do you have how to for cloud computing with ubuntu –  Rajat Apr 20 '10 at 6:35

Thank you very much for the reply.

I manage to solve this problem. Just use the following command:-

source ~/.euca/eucarc

I found the following information from the internet:-

...should have created a "eucarc" file with important environment variable information within it. You will need to source the eucarc to run the ec2tools in your environment...

Thank you.

Patrick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.