Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm moving to Google Apps and have setup dual-delivery. Everything is fine, but for mail sent internally (from sally@mydomain.com to john@mydomain.com), Exchange is not using the send connectors I have pointing to Google's servers.

I believe my question is similar to this question: How to force internal email through an smtp connector in exchange 2007

Again, if a user is connected to the Exchange server and tries to send to george@outsidedomain.com it works just fine, but I cannot seem to force *@mydomain.com to route correctly.

This should be a fairly simple, but according to this:

google.com/support/forum/p/Google+Apps/thread?tid=30b6ad03baa57289&hl=en (can't post two links due to spam prevention)

It does not seem possible. Any ideas?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I think the only way would be to create an alias domain called google.mydomain.com, register that domain as an alias with Google Apps, and then create Active Directory Contacts for each user:

John Forwarder email address: john@google.mydomain.com

Sally Forwarder email address: sally@google.mydomain.com

Once that's done, open up the Exchange General properties (I think, it's one of those tabs) under Active Directory Users and Computers for each user and set the mail to forward to the corresponding "John Forwarder" contact (make sure the "send to both email accounts" checkbox is enabled or the like, again, I'm not on a server right now).

That's the gist of it, I can fill in specifics later on today if need be.

share|improve this answer
    
This works, you do not need to use the send connector, in fact that seemed to keep mail from going out. You don't need to modify any other DNS/MX settings either (except for those to get it going with Google Apps). Thanks! –  Geoffrey Apr 19 '10 at 20:06
    
yeah, that makes sense: by setting the appropriate MX records for google.mydomain.com, the mail will just route as normal through your default Send Connector. –  gravyface Apr 19 '10 at 20:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.