Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been tinkering/testing with Ubuntu Server 10.04 Beta LAMP stack in a VM and now I've come to the Redmine install. I found a package for it, and issued:

sudo tasksel install lamp-server
sudo apt-get install redmine

Which (I think almost) worked, but I've no idea how to test it, or even know if it's configured.

How do I test it? I'm using 10.04 server so I don't have a local GUI.

share|improve this question
1  
I should mention that this installation methodology is the current i'm hoping to get to work, having tried several how-to's, not the least of which is the install guide on the Redmine site itself. –  Jamie Apr 19 '10 at 18:52
    
I'm guessing you've never setup a web application like Joomla, Drupal, Wordpress, etc. right? –  gravyface Apr 19 '10 at 18:56
    
Not much of a guess, but yeah. Beyond setting up Apache to control my access to subversion repositories and serve up static html, I'm really a user who administers when I need the tools to run. –  Jamie Apr 19 '10 at 19:04

4 Answers 4

up vote 4 down vote accepted

Unfortunately the redmine Ubuntu package requires some manual configuration before you can get started. Now that redmine is installed, you still have to make it accessible through a real web server. An easy way to do this is with Apache with the mod_passenger plugin.

Just edit your /etc/apache2/sites-available/default (or default-ssl), adding:

RailsBaseURI /redmine
PassengerDefaultUser www-data

Then configure /etc/redmine/default/database.yml as necessary and run ln -s /usr/share/redmine/public /var/www/redmine. That should do the trick.

You can read more at http://www.redmine.org/wiki/1/HowTo_Install_Redmine_in_Ubuntu.

share|improve this answer

What happens if you to http://IP.address.of.server?

At some point during the Redmine install you would've likely setup an Apache virtual host that would've had a ServerAlias directive with somedomain.com, assuming you have DNS setup for that domain to resolve to your VM's IP address. If not, you can get away with editing your HOSTS file.

If so, you need to go to http://somedomain.com in your browser to see/use Redmine.

share|improve this answer
    
Half the battle here is describing my problem, the other is not having configured apache servers. I can hit the apache server with "ww.xx.yy.zz"; and see static content, but I don't know where I'd find the redmine ... does it come up on a non-standard port, or should it be 'right there'. My first desire is to see if the package installed correctly. –  Jamie Apr 19 '10 at 19:12
    
I usually install Web applications manually (because I like to see what's going on, make sure each step works ok, etc.). However, you should be able see if the installer created a new Apache site in /etc/apache2/sites-enabled –  gravyface Apr 19 '10 at 19:17
    
@gravyface: Not an answer, but it does give me some threads I can read up on (virtual host configuration, which didn't happen). Thanks for the lead. –  Jamie Apr 20 '10 at 15:09
    
How is that not an answer? You gave very little, but yet I answered your question correctly and directly. –  gravyface Apr 20 '10 at 16:45
    
If want a different answer, then you'll need to revise your question accordingly. –  gravyface Apr 20 '10 at 17:00

I got this error:

Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

So in order to apache2 configuration work ( RailsBaseURI /redmine and PassengerDefaultUser www-data ) I needed to install Passeger lib.

  $ sudo apt-get install libapache2-mod-passenger
share|improve this answer

This tutorial (complete with screencast video) works like a charm for me;

http://www.techrecipes.net/web/redmine/install-in-ubuntu

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.