Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed an OCS/GLPI configuration using RHEL5. I've configured GLPI to authenticate to our AD, which it does, however, none of the AD user details appear after logging in. It will create the user account & just show a number. I am able to successfully see AD groups but not users. I verified the data request & response using wireshark & it is returning the proper syntax for rootdn & basedn yet no data will populate. We are a small company with few users so no elaborate OU's are present. To compound matters, the project is primarily in French which I unfortunately do not speak. I've tried posting to their boards but am getting very little response so I was hoping some of you might have some ideas that I could try ?

I've added a screenshot of my config here'>' border='0' alt='Image Hosted by'/>

I'm also using the latest version 0.71.5, downloaded 5/11/09

share|improve this question
up vote 2 down vote accepted

Please compare your LDAP config to the following screenshot, make sure the AD->GLPI mappings are the same. By default you also have to use an authenticated AD user account to retrieve info from AD.

I am currently on version 0.71.5. I have also tried project forums in the past, but they were of not help. They claim they will start documenting everything in English once they have more English-speaking developers...

share|improve this answer

The solution is to enter "samaccountname" (in the login field) all in lower case rather than being case sensitive like all the other fields. You then must use an AD account (in the rootdn field) to retrieve the details as shown in the other screen shots.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.