Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem that googling has turned up nothing, except this question on experts exchange which I borrowed most of the text from. :)

When I connect via Remote Desktop to a new Windows 2008 R2 server it takes 20-30s to get past the "Securing Remote Connection" message during the login.

If the password is wrong, it does this every time you attempt a login (ie its not a one time thing). However, after a successful login attempt the following logins to the same server goes faster.

Most servers runs on VMware here, but I don't know if that has anything to do with it.

share|improve this question
    
I've seen the same issue on our TS's (which are also VMWare) but thankfully we've got such a small userbase on those TS's it hasn't been an issue worth fixing for us –  Mark Henderson Apr 23 '10 at 10:44
    
JohannesH, did you ever find a solution that worked. I'm having the same problem. –  Caleb_S Jan 17 '12 at 1:16
    
@Caleb_S Sorry but I never really figured out what caused it. Though I'm pretty sure it had to do with the servers not being able to connect to the primary DC. However, one day the problem just stopped and nobody could explain why. We've since closed that domain entirely and restructured our network. So I don't think I'll see that problem again. –  JohannesH Mar 5 '12 at 8:21
add comment

6 Answers

up vote 3 down vote accepted

Do you have access to your local DNS Server? You may have some entries in the local zone for AD servers that no longer exist or have had IP's changed. Last year I removed a DC from the network and it caused a delayed login via RDP.

share|improve this answer
1  
Thanks, I'll check it out tomorrow. –  JohannesH Apr 28 '10 at 21:17
    
any luck with checking out DNS? –  iainlbc May 1 '10 at 1:58
1  
I wasn't able to find any wrong entries regarding dc servers or otherwise, on any of our internal dns servers. –  JohannesH May 1 '10 at 18:59
    
Hi, may you please test rdp after disabling UAC on the server? –  iainlbc May 1 '10 at 19:42
    
Hi Ian thanks for the suggestion... I will test it when I come back from my vacation in about 4 weeks (end of may). Au revoir! :) –  JohannesH May 2 '10 at 1:17
add comment

I agree that this sounds like a DNS issue on your 2008 R2 server. Verify that the correct DNS servers are entered on the 2008 R2 server's TCP properties. Also, as recommended previously, review your DNS server for invalid entries.. specifically look for invalid entries in the _msdcs, _sites, _tcp, etc containers/subcontainers. You can also attempt a local login to rule out network issues though if you determine the issue is only via RDP you can look into TCP auto tuning settings on the clients.

share|improve this answer
add comment

For anyone that searches this, try disabling IPv6 on the Remote Desktop server - we have Server 2008 running as a Remote Desktop server connected to a 2003 domain controller. Disabling IPv6 on the remote desktop server made this go from 20-30 seconds to instant :)

share|improve this answer
add comment

I've seen happen on 2008 R2 machines running on ESX 3.5; sometimes the machine's virtual console would freeze (probably a video driver bug) while the system would remain online, and RDP connections would hang like that.

Next time this happens, you should try to connect to the server's console and see if it's working.

share|improve this answer
    
The console works fine (99.9% of the time)... If its slow its usually due to the default graphics drivers. Thanks for the suggestion. –  JohannesH Dec 29 '10 at 4:09
add comment

If the video driver bug is not the source of this, than it could be an authentication or RDP problem.

  • Does it happen when you log on to the server's console (using the VMware client)?
  • Does it happen if you log on with a local user account instead of a domain one?
share|improve this answer
    
It seems a local user works much better than the domain user I normally use. Do you have any suggestions how to debug this case? –  JohannesH Apr 26 '10 at 11:23
    
Sounds like a domain logon problem. What happens if you log on to the server's console (using VMware client) with a domain user? –  Massimo Apr 26 '10 at 12:46
    
Logging into the server with a domain user using the vSphere CLient Console works pretty fast. –  JohannesH Apr 26 '10 at 12:53
    
What about a domain user which never logged on to that server? Cached logons can be pretty fast even if a DC is unreachable. Also, do you have any error on the server's System and Application event logs? –  Massimo Apr 26 '10 at 13:06
    
It's the same whether or not the user has been on the server before. regarding the event log I only found some errors regarding rdp sharing of printers, so I disabled the printer in the remote desktop options, though it didn't do any better. –  JohannesH Apr 28 '10 at 11:47
show 3 more comments

I had the same problem after upgrading from SBS2008 to 2010. After migration and removing the 2008 RDP hangs after every action. I had to search for incorrect records in the DNS and found about 5 entries. After cleanup RDP works again.

share|improve this answer
1  
Yeah, the dns is most likely the problem when you have an issue like this. –  JohannesH Dec 28 '10 at 9:50
add comment

protected by Community Jan 16 '12 at 17:29

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.