Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Having installed Team Foundation Server 2010 on Windows Server 2008, I need an easy URL for our developers to access their repositories.

The default URL for the TFS repositories is http://localhost:8080/tfs

Now I want the subdomain domain to point at http://localhost:8080/tfs. And when you access it should redirect to http://localhost:8080/tfs/repos_name.

How can I do this in IIS7?

I already tried using the following rule, but it does not work. I get a 404.

  <rule name="TFS" stopProcessing="true">
   <match url="^(?:tfs/)?(.*)" />
    <add input="{HTTP_HOST}" pattern="^$" />
   <action type="Rewrite" url="http://localhost:8080/tfs/{R:1}" />


I actually got this working by adding a binding for the site on port 80 with host name

But using, I can't authenticate using Windows Authentication. Is there something that I need to configure for Windows Authentication?

You can see a trace here:

share|improve this question

Does it work still when using the http://localhost:8080/tfs link? The authentication is probably unrelated to the URL pattern.

Are you only testing from localhost? If so you may be running into the loopback check issue: Try testing from another machine and it may work for you, or you can make either of the changes in that KB article.

share|improve this answer

Have you tried changing it in the Team Foundation Server Administration console? And you can also change the URL with this command:

C:\Program Files\Microsoft Team Foundation Server 2010\Tools>tfsconfig settings /notificationUrl:

Our TFS 2010 was for example installed on a VM and the people from infrastructure followed their naming conventions, and that machine was named BEL-VM-TFS. But everybody now connects to it with

Beside that we had to add an ALIAS "TFS" on the DNS server that points to the server "BEL-VM-TFS.

share|improve this answer
When I try to change the notification URL to, it gives me a 404 error when testing it, using the administration console. – Tommy Jakobsen Apr 21 '10 at 19:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.