Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm configuring Transactional Replication using the Push model. The scenario is:

The SQL Servers:

  • SQL01 (publisher) and SQL02 (subscriber) - both running SQL 2000 SP4.
  • Both servers are standalone (i.e. not domain members)
  • Both servers have their FQDN and NETBIOS names in their HOSTS files

I've managed to configure SQL01 to publish my database and configured a Push subscription for SQL02 using the Push New Subscription wizard and set the Distribution Agent to update the subscription continuously.

On the Push Subscription wizard "Initialise Subscription" page I've selected "Yes, initialise the schema and data" and ticked the "Start the Snapshot Agent to begin the initialisation process immediately" option.

All the required services are running (SQL Agent).

When I complete the wizard and browse the Replication -> Publications folder I can see my publication (blue book with arrow). The publication shows the Push subscription and its status is Pending.

If I look in the c:\Program Files\Microsoft SQL Server\Mssql\Repldata folder I see a number of T-SQL scripts for each table e.g. Products.bcp, Products.sch, Products.idx.

What should happen now? Should my replicated database now (magically) appear on the subscription server?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Got this working, didn't realise I had to create an empty database on the subscriber server first. The SQL 2000 Books Online documentation isn't very clear about that.

share|improve this answer
    
Would it be possible for you to show me how you configured that HOSTS file? just use "foo" names, I just need to see how you specified what. I made mine by using "client network" configuration and then ALIAS... dont know if that the reason for my current problem with setting these up. –  BerggreenDK Aug 24 '10 at 1:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.