Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a simple way to install Ruby 1.8.7 on Fedora 11 or 12 without side-stepping the yum/RPM package management system too severely? Building from source is always an option, but it tends to deploy things in irregular places and proves to be more fuss to maintain in the long run.

A self-built RPM is okay, but I'm presuming there's a .rpm out there somewhere already. Rails is not especially happy with 1.8.6 and the Fedora community, for various reasons, considers 1.8.7 to be toxic and best avoided.

Edit:

One suggestion I've received is to use rvm

share|improve this question

2 Answers 2

up vote 2 down vote accepted

RVM may not work today on Fedora 12. The problem is to compile Ruby against the openssl-1.0.0(beta 3 or 4) version packaged with F12: It does not work.

The Ruby Core community is aware of the problem, and fixed it. The code is patched in the ruby1-8-8 and ruby1-9.x development branches. But then, it is difficult to get these patches with RVM. RVM will fetch a specific version from "stable" repositories (not sure it is the appropriate term), e.g.

rvm install 1.8.7-p174  # <= Will NOT work today!

Which does not include yet the above patches. And if you try with RVM to get the latest version of the 1.8.7 core like p278, some independent segfaults problems occur (one reason why the RVM documentation recommends the p174 one).

If you need a working Ruby quick, an install from source works well on F12. It was the solution I chose, waiting for patched versions manageable by the very helpful RVM.

share|improve this answer
    
rvm is working well on Fedora now. You need to use the rvm package installer for OpenSSL. –  tadman Sep 22 '10 at 16:55
    
rvm list known will show all the available versions of Ruby that rvm can install. I use it all the time and prefer it over yum/apt or manually installing from source. –  Greg Sep 25 '10 at 23:10
    
How do you make 1.8.7 the default ruby version? Even after the install, 1.8.6 is still the default... –  Cerin Dec 28 '11 at 19:51

for those of us with old fedora (10), installing from source rpm works OK:

  1. use REHL5 source rpm wget http://www.cherpec.com/wp-content/uploads/2009/10/ruby-enterprise-1.8.7-1.el5.src.rpm

  2. install build prerequisites: sudo yum install gcc-c++ readline-devel ncurses-devel gdbm-devel autoconf openssl-devel db4-devel byacc ruby

  3. locate your built-rpm directory (perhaps /home/$username/rpmbuild/RPMS/$arch) and install the rpm you built: sudo yum install ./ruby-enterprise-1.8.7-1.el5.i386.rpm --nogpgcheck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.