Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

im very new to this. I've set up an account "SQLBOX" thats on the a network, but not connected to the domain. I have installed an instance of SQL Server 2008 and am trying to connect to it from another machine on the network but am getting "Cannot connect to "SQLBOX"". From the "SQLBOX" i can connect to sqlservers on the domain, but not vice-versa. Any help would be greatly appreciated. Sorry if the description isn't great.

EDIT

I can ping the box from a machine on the domain

share|improve this question

migrated from stackoverflow.com Apr 21 '10 at 19:34

This question came from our site for professional and enthusiast programmers.

    
Are you trying to connect to sqlbox using sql server enterprise manager or using a database link between the non-domain and the domain? –  James B Apr 21 '10 at 15:27
    
Im connecting using SQL Server Management Studio on a machine on the domain, to the server (not on the domain) "SQLBOX" –  Ben Apr 21 '10 at 15:34
    
Not great. What have you tried? Did you enable TCP/IP on the SQL Server? Did you allow remote connections? Is your firewall open on the right port? Lots of things we need to know before we can help. –  user3914 Apr 21 '10 at 17:19
    
I've enabled TCP/IP on the SQL Server. How do you allow remote connections (i assume your not talking about remote desktop connections)? It's a fresh box and has no firewall on it yet. Thanks. –  Ben Apr 22 '10 at 8:23
add comment

5 Answers

The default for SQL Server 2008 is:

  1. sa account is disabled by default
  2. port 1433 is not actually listening, you need to enable it and make sure you bind it to the ip address that your expecting (not a required step). (i usually disable IPv6 on my network adapter on this one to simplify a little)
  3. if your using the SA account, enable SQL authentication because its not enabled by default
  4. verify that windows firewall added an exception for SQL Server process
  5. finally, network auth sometimes will get you and so if your having trouble, change the user account that the SQL server process runs under. (i usually run my SQL server as the currently logged in user to get around that problem)
share|improve this answer
add comment

Make sure you have SQL Authentication enabled on the server outside the domain (so you're not using Built-In Windows authentication).

You'll have to then create SQL Accounts for every user you want to connect to your server.

share|improve this answer
    
I've done that. I still get "Cannot connect to SQLBOX" from the machine on the domain. Is there anything else i need to change on the server? Cheers –  Ben Apr 21 '10 at 15:25
    
Have you tried accessing the box using the IP address rather than the machine name? You could be having problems with a WINS lookup failing fromt he domain to the machine outside the domain. –  Justin Niessner Apr 21 '10 at 15:29
    
Yeah, i've tried using the IP address, no luck. –  Ben Apr 21 '10 at 15:34
add comment

Check the firewall rules on both machines and between them. Port 1433 needs to be open.

share|improve this answer
add comment

Run SQL Configuration and make sure the TCP/IP port and IP enabled. It's disabled by default

share|improve this answer
add comment

I guess you are trying to connect to your new SQLBOX with the SSMS, aren't you? For this it is not necessary that the server is part of your domain as long as your are using the SQL authentication and not the Windows authentication of SQL Server.

On the new box you should check which IP address the new box has and use this IP instead of the name to connect to the server using the SSMS.

If this does not succeed then it would be useful if you could provide us with exact error message which you receive when trying to connect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.