Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Description

I have 2 systems with me, one running on Windows(Host) and one on Ubuntu, both on a LAN. On the Windows(Host) I develop software intended for the Linux system and because the Linux system has little external memory, my idea to overcome this is by making the project folder on the Host side a Shared Folder with full access and access it on Ubuntu over the network. To achieve this, I have installed Samba on Ubuntu, when I go to Places -> Network I can see the shared project folder and I simply mount it. A link appears on the desktop. Next, using Nautilus I open the link and I can access the contents of the shared folder.

Problem

Even though I mount the shared project folder, I don't see it appearing in the /media or the /mnt folder, as a result of this I don't know what path to use to access this folder, from the terminal.

For example: When, I mounted my USB stick, as expected, a link for the device appears on the Desktop and I also see a folder in the media folder. So, similarly, a mounted shared folder should have appeared on the /mnt folder, too.

Can anyone suggest what I should do now? There are many posts around, but no solid solution for this problem.

Help!!! :)

Vikram

share|improve this question

migrated from stackoverflow.com Apr 22 '10 at 18:40

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

You need to mount it properly from the command line, like real men do :

sudo mount -t cifs -o username=user,password=password //server/share /mnt/yourmountpoint

share|improve this answer
1  
That definitely sounds like the proper solution. Is there any way to do it without root access? –  levesque Oct 30 '10 at 15:59
    
You may add the proper line to the /etc/fstab file, with the "user" option: //server/share /mount/point cifs user,username=user,password=pass 0 0 –  wazoox Nov 5 '10 at 16:05
add comment

First, you need to install gvfs-fuse by the following command

apt-get install gvfs-fuse

Then, re-login and mount the shared directory by Place -> Network. Now you can see the shared directory in $HOME/.gvfs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.