Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm managing several Ubuntu 9.10 servers that NFS mount several folders (including /home). I'd like these folders to be mounted at boot time. I would like to have several entries in my /etc/fstab to accomplish this, e.g.

192.168.1.100:/home           /home           nfs     rw 0 0
192.168.1.100:/usr/ansys_inc  /ansys_inc      nfs     ro 0 0

Unfortunately, with this configuration, the servers usually (although not always) hang during the bootup sequence when trying to do the NFS mount.

if I comment out these fstab entries, reboot the machine, uncomment them and mount them manually using the shell, the folders mount cleanly.

I'm not sure how to go about debugging this problem. It seems like it has something to do with the boot sequence, that some relevant process hasn't been started by the time the OS tries to mount the folders.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

Try the _netdev option for that filesystem in /etc/fstab.

  _netdev  

          The filesystem resides on a device that requires network  access
          (used  to  prevent  the  system  from  attempting to mount these
          filesystems until the network has been enabled on the system).
share|improve this answer

Make sure that networking starts before NFS. I've seen this happen a bunch of times on Debian boxes.

share|improve this answer

had the same issue, on CentOS 5.3, i did

1) enable;

spanning-tree portfast default 

on the switch (cisco)

2) changed the nfs mount in fstab to

server:/dir   /dir   nfs   _netdev,rw,bg,hard,intr   0  0

and now it works just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.