Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to create a full-text index on my new full-text catalog and got this error:

Msg 9967, Level 16, State 1, Line 1
A default full-text catalog does not exist in database 'foo' or user does not have permission to perform this action.


  • I connected to the target sql server with Windows Authentication
  • Full-text indexing appears installed (right-clicking the table, I see the Full-text Index -> option)
  • I verified that my full-text catalog was created
  • This is my first time setting up a full-text catalog and index

What do I need to do in Sql Server 2005 and/or in Windows Server 2003 to get permissions?

Please be thorough (assume I am a sysadmin n00b). Thank you.

share|improve this question
up vote 3 down vote accepted

If you have the database-owner permission, that's all you need to do there.

Full-text indexing is an option in the SQL Server installer. You may need to go back and add the feature.

Other than that, these instructions should take care of you:

share|improve this answer
Thanks @Miles. Your link showed me my fault. The error was with the "default catalog" part--not the permissions. Once I added ON MyCatalog to the SQL statement, it worked. – Bill Paetzke Apr 23 '10 at 17:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.