Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to create a full-text index on my new full-text catalog and got this error:

Msg 9967, Level 16, State 1, Line 1
A default full-text catalog does not exist in database 'foo' or user does not have permission to perform this action.

FYI--

  • I connected to the target sql server with Windows Authentication
  • Full-text indexing appears installed (right-clicking the table, I see the Full-text Index -> option)
  • I verified that my full-text catalog was created
  • This is my first time setting up a full-text catalog and index

What do I need to do in Sql Server 2005 and/or in Windows Server 2003 to get permissions?

Please be thorough (assume I am a sysadmin n00b). Thank you.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

If you have the database-owner permission, that's all you need to do there.

Full-text indexing is an option in the SQL Server installer. You may need to go back and add the feature.

Other than that, these instructions should take care of you:

http://sqlserverpedia.com/wiki/FTS_-_How_to_use_TSQL_to_Create_Full-Text_Indexes

share|improve this answer
    
Thanks @Miles. Your link showed me my fault. The error was with the "default catalog" part--not the permissions. Once I added ON MyCatalog to the SQL statement, it worked. –  Bill Paetzke Apr 23 '10 at 17:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.