Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed the hyper-v role on a DL580 G5 cluster. The host operating system is a server 2008 x64 patched to the maximum. Everything has gone fine, but if I install a guest operating system, actually a windows server 2008 x64 I can't reach the network from it. It send many packets, but don't received any, so I can't ping the external network as well. I have installed the latest drivers to the server and unintalled the network configuration utility from the physical server, but no luck. I added a legacy adapter to the guest binded to the same phisycal adapter on the host machine but it can't help Any idea welcome...

share|improve this question
up vote 0 down vote accepted

Optineer: This one may not have anything to do with Hyper-V. Check your switch (or have network admin) for port security attribute on the physical port. I've seen where a setting can limit the number of MAC addresses that can register with the physical switch port at one time, if this setting is less than the number of host + VM MACs, you can see issues like this. You'll see many arps sent from the adapter in a network trace, but none returning, you may also see "rejections" in the switch logs.

share|improve this answer
Thanks, this helps. I search the problem inside, but it was outside. I reconnect the server to another switch and now the communication is working from the virtual machine to the physical LAN. – user41444 Apr 28 '10 at 11:33

What network type did you set up? You're best off using bridge, but you have to make sure you configure the firewall on the host afterwards accordingly

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.