Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

we're moving from Solaris to Redhat Linux, and trying to duplicate our low-latency setup, that, on solaris, includes the ndd settings related to TCP NO DELAY, and NAGLE ALGORITHM. I got the impression that those parameters are not all configurable system-wide, but still found some info.

we have configured our applications to run with no nagle algorithm, but that is not sufficient.

we have found an interesting RH article talking presenting the tcp_delack_min parameter, however, when browsing /proc/sys/net/ipv4/ , I can't find it there. would it be safe to assume that simply "adding" the parameter as it's said on the doc would be enough, or rather that the option is not supported by this version (would be strange, as RH specify that it "can be performed on a standard Red Hat Enterprise Linux installation") ?

any other idea / recommendation to improve latency further ?


share|improve this question

TCP_NODELAY and Nagle are both per-socket on linux.

Running a realtime kernel might help.

share|improve this answer
agreed. the article mentioned is actually the documentation of the real-time kernel of RH (marketed as MRG). they basically say that BEFORE switching to a real-time kernel, there are a few tune-ups that should be done on a REGULAR system / kernel. one of those parameters is the "tcp_delack_min" one. my point would be to handle this BEFORE considering switching to a real-time kernel. – Bastien Apr 26 '10 at 3:23
up vote 0 down vote accepted

the tcp_delack_min is a tcp parameter that is only available in the MRG "version" (realtime kernel) of RHEL, even though their docs says it's an optimization that should be performed before attacking more "real time" tasks.

share|improve this answer
This parameter seems to be missing in more recent MRG kernels. – ewwhite Jul 12 '11 at 15:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.