Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've an old hp1100 and ubuntu 9.10 and now upgraded to lucid prerelease. I can't see my printer on network (using smb://mycomputer on nautilus or \mycomputr from xp). As long as i will not restart smbd (on lucid: sudo restart smbd) my printer is not visible as network share. All file shares are always visible. My printer is visible and working after smbd restart

Any clue what might cause this ?


Easiest way to workaround this (at least in ubuntu 11.04 where this issue is still not solved) is to edit upstart smbd file located at:


and replace line:

start on (local-filesystems and net-device-up)


start on (local-filesystems and net-device-up and started cups)
share|improve this question
up vote 1 down vote accepted

Most likely is that samba is coming up before cups, I suggest you report a bug to launchpad.

share|improve this answer
seems bug is already filled at: anyway thanks :) – tomaszkubacki Apr 26 '10 at 16:40

I had the exact same problem this morning (Ubuntu 11.04 - You would think they would fix this by now...). I determined the problem after some Googling. Yes, Samba is starting before CUPS, which causes Samba to not display the printers until you manually do 'sudo reload smbd'.

I modified /etc/init/cups.conf, not /etc/init/smbd.conf (basically adding "or starting smbd" to the end of the line)

start on (filesystem
    and (started dbus or runlevel [2345])
    and stopped udevtrigger) or starting smbd

I like this solution because it works for people with only CUPS installed or people with only Samba installed (I think). Hope this helps someone out there...

share|improve this answer

Better is not to tinker with the installed upstart files, but to add to /etc/rc.local

service cups restart 
service smbd restart

But you would indeed think they would have fixed this by now -- but no, I installed Xubuntu for a neighbour last night and the same thing happened. It's nearly as bad as the old error of starting network-dependent services on a laptop (where there might not be a connection at any given time) and then having a 10-minute timeout...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.