Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We bought a Dell PowerEdge 860 and installed Windows Server 2008 standard. So far so good.

Now everytime the server reboots, it tries to PXE boot and hangs on cannot find pxe bootable, press f1 to continue or f2 to setup.

Iried all the settings in the bios (it's the latest - A05), I have the NIC active without PXE (I also tried with the nic off). I tried everyting off and on the BIOS and it still goes to PXE booting.

I have one SATA drive that boots after pressing F1. I would like to keep the system updated, but I can't because of the reboot issue. Can someone point me in the right direction?

Disk Drives:

  • ST3250620NS ATA Device 232.8Gb

IDE ATA/ATAPI Controllers:

  • Intel(R) 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF
  • Intel(R) 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller - 27C0

The only time that BIOS POST message says that it can't find the drive is when in the bios I turn on the second SATA drive (that really dosen't exists).

What other details on the server would you like?

share|improve this question

4 Answers 4

If it still tries to pxe boot even if it is turned off then logically you must have faulty hardware.

Perhaps a BIOS/Firmware update might fix it otherwise it's one for Dell's technical support.

share|improve this answer
    
But just to know, is there a option in bios that explicit turn off the pxe boot? The only thing i found was a "nic without pxe". –  Berto Apr 26 '10 at 11:31
1  
That sounds like the relevant option. Best to give Dell a call. –  Jon Rhoades Apr 26 '10 at 11:40

Look in the BIOS for the "Boot Order". Move the PXE option(s) to be after the hard drive. On some systems you can remove it entirely from the boot order list.

share|improve this answer
    
In the boot order list i only have the hardrive, nothing else. I'm going to check if i have all the updates of firmware (again). And if nothing else, check if dell... agrrrr –  Berto Apr 26 '10 at 13:23

It sounds to me like it's attempting a PXE boot because it can't find the hard drive. When you installed W2K8, did it in fact see the hard drive and install to it? Does the server have a RAID controller? Is the RAID controller seen during POST?

share|improve this answer
    
On installation it had a hardrive, and don't have RAID. In BIOS post, dosen't post anything about harddrives... –  Berto Apr 27 '10 at 11:09
    
That's probably the problem then. If no HDD's are seen during POST then it's going to attempt a PXE boot because it doesn't see a bootable HDD. –  joeqwerty Apr 27 '10 at 15:27
    
Then why does it post the hardrive not found when i activate the sata 1 drive (that dosen't exist). By the logic even that i wuold activate the sata where dosen't have a hdd, it should only say that after the pxe boot. My problem is the time that i could dedicate to this, is short, so the solutions that i have i can only try from time to time. –  Berto Apr 27 '10 at 17:07

is there more than one nic? almost all the Poweredges we have contain multiple nics, ensure all of them are enabled without PXE (or disable all the other nics. all additional network cards installed too?)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.