Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to install a WMI client on to a ubuntu server to manage some windows web servers. The only WMI client I've found is compatible with Intrepid 8.10, whereas my server is currently running Karmic 9.10. So, can I install the old package on Karmic?

http://packages.ubuntu.com/search?keywords=wmi-client

share|improve this question

3 Answers 3

Download the .deb, for example the i386 version from the French mirror to your desktop and click on it.

GDebi will open and ask if you want to install it. Say "Yes" and enter your password when prompted.

If you can install it it will install.

If you cannot install it, then it will tell you why you cannot install it.

I am not particularly familiar with this package but there is a reasonable likelihood it will install and work, and if it installs but doesn't work, you can just uninstall it again.

I have half a dozen or so "old" deb packages I have installed from Jaunty onto Lucid for support for games and they all installed and ran without any problems.

share|improve this answer

You could try to rebuild the package for Karmic, get the src, dsc, diff files for interpid unpack with dpkg-source -x xxx.dsc and try to build with:

$ dch -n
# update, version-number
$ dpkg-buildpackage -rfakeroot -us -uc

You may need to change some things but often it just works building it.

share|improve this answer
up vote 0 down vote accepted

Downloaded the .deb file as suggested above, and then used dpkg -i, seems to work thus far, but we'll see...

share|improve this answer
    
Thanks for posting back and providing feedback. –  Richard Holloway Apr 27 '10 at 13:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.